PAT 1012 The Best Rank

原题目

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题目大意

给出学生ID和每位学生三门课程的成绩和想知道自己成绩的学生ID,求各位想知道成绩的学生三门课程及平均分中排名最好的一门的名次及课程名。
输入的第一行包含两个整数NM,分别表示总学生数和想知道自己成绩的学生数。之后的N行输入每名学生的ID及三门课程的成绩。接下来的M行是想查询自己成绩的学生的ID。输出M行,分别表示每位想知道自己成绩的学生的最佳排名。若该学生不在成绩表中则输出N/A

题解

想了半天不知道用啥数据结构来存,最后还是选择了最简单的方法,直接O(n2)遍历求得每门课程对应的排名。
为方便输入和比较,学生ID直接采用long long型存储。

C语言代码如下:

#include<stdio.h>
#include<stdlib.h>
int n, m;

void find(long long *id, long long query, int *A, int *C, int *M, int *E){
    for(int i = 0;i < n;++i){
        if(id[i] == query){
            int minn = n + 1;
            int index;
            int score[] = {A[i], C[i], M[i], E[i]};
            for(int i = 0;i < 4;++i){
                if(score[i] < minn){
                    minn = score[i];
                    index = i;
                }
            }
            switch (index)
            {
            case 0:
                printf("%d A\n", A[i]);
                break;
            case 1:
                printf("%d C\n", C[i]);
                break;
            case 2:
                printf("%d M\n", M[i]);
                break;
            case 3:
                printf("%d E\n", E[i]);
                break;
            default:
                break;
            }
            return;
        }
    }
    printf("N/A\n");
}

int *rank(int *grades){
    int *ret = malloc(sizeof(int) * n);
    for(int i = 0;i < n;++i) ret[i] = 1;
    for(int i = 0;i < n;++i){
        for(int j = 0;j < n;++j){
            if(grades[j] > grades[i]){
                ret[i]++;
            }
        }
    }
    return ret;
}

int main(){
    scanf("%d%d", &n, &m);
    long long *id = malloc(sizeof(long long) * n);
    long long query;
    int *C = malloc(sizeof(int) * n);
    int *M = malloc(sizeof(int) * n);
    int *E = malloc(sizeof(int) * n);
    int *A = malloc(sizeof(int) * n);
    for(int i = 0;i < n;++i){
        scanf("%lld%d%d%d", id + i, C + i, M + i, E + i);
        A[i] = (C[i] + M[i] + E[i]) / 3;
    }
    int *rankA = rank(A), *rankC = rank(C), *rankM = rank(M), *rankE = rank(E);
    for(int i = 0;i < m;++i){
        scanf("%lld", &query);
        find(id, query, rankA, rankC, rankM, rankE);
    }
    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 200,738评论 5 472
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 84,377评论 2 377
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 147,774评论 0 333
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,032评论 1 272
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,015评论 5 361
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,239评论 1 278
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,724评论 3 393
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,374评论 0 255
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,508评论 1 294
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,410评论 2 317
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,457评论 1 329
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,132评论 3 316
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,733评论 3 303
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,804评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,022评论 1 255
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 42,515评论 2 346
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,116评论 2 341

推荐阅读更多精彩内容