PAT Advanced 1012. The Best Rank (25) (C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

To evaluate the performance of our first year CS majored students, we consider
their grades of three courses only: C - C Programming Language, M -
Mathematics (Calculus or Linear Algrbra), and E - English. At the mean
time, we encourage students by emphasizing on their best ranks -- that is,
among the four ranks with respect to the three courses and the average grade,
we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are
given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done
the best in C Programming Language, while the 2nd one in Mathematics, the 3rd
one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line
containing 2 numbers N and M ( \le 2000 ), which are the total number of
students, and the number of students who would check their ranks,
respectively. Then N lines follow, each contains a student ID which is a
string of 6 digits, followed by the three integer grades (in the range of [0,
100]) of that student in the order of C, M and E. Then there are M
lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and
the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M >
E. Hence if there are two or more ways for a student to obtain the same best
rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

思路

计算排名的方法:

很多人用的结构体排序,这样是比较耗时的(尤其是基数很大的时候)。

我的方法是在读取学生成绩的时候顺便记录0~100分各有多少人,然后根据得分人数计算排名。举个例子:

  • 如果100分有1人,99分有2人,98分有3人,97分有4人。

那么

  • 得100分的排名是1,得99分的排名是2(并列),98分的排名是4(并列),97分的排名是7(并列)。

规律是什么?如果学生获得的分数分别有a1>a2>a3>...>ai>...,那么

  • 分数a[i]的名次 = 分数a[i-1]的名次 + 分数a[i-1]的人数
  • 分数a[1]的名次 = 1

这其实是递归定义,如果定义一个不存在的高分a0(比如101分)人数=1(代码中一开始的初始化就是做这个),那么上面的关系就简化成了

  • 分数a[i]的名次 = a[0]~a[i-1]的人数总和,(i>0)

可以验证一下:97分的排名=98~101分人数总和=3+2+1+1=7

平均分计算方法:

仔细看题目中给的例子,平均分是四舍五入的,不过我试过在算平均分的时候直接3个数相加除以3,还是能AC。所以要不是题目没有设置这样的测试点,要不就是题目认为两种算法结果都正确。

代码

最新代码@github,欢迎交流

#include <stdio.h>

typedef struct Student{ int ID, score[4]; } Student;

int main()
{
    /* scores array stores the number of students of any score */
    int N, M, ID, scores[4][102] = {{0}};

    /* Setting a score of 101 is to make it easy to calculate rank */
    scores[0][101] = scores[1][101] = scores[2][101] = scores[3][101] = 1;
    Student students[2000];

    scanf("%d %d", &N, &M);
    for(int i = 0; i < N; i++)
    {   /* record all the scores for every student: A, C, M, E */
        Student *s = students + i;
        scanf("%d %d %d %d", &s->ID, &s->score[1], &s->score[2], &s->score[3]);
        s->score[0] = (s->score[1] + s->score[2] + s->score[3] + 1) / 3;
        for(int j = 0; j < 4; j++)                         /* +1 for rounding */
            scores[j][s->score[j]]++;       /* record how many got this score */
    }

    for(int i = 0; i < M; i++)
    {
        int max = 3, ranks[4] = {0}, stu;

        scanf("%d", &ID);
        for(stu = 0; stu < N && students[stu].ID != ID; stu++) ;      /* find */
        if(stu == N) { puts("N/A"); continue;}

        for(int j = 3; j >= 0; j--)
        {   /* calculate the rank: sum the counts from score + 1 to 101 */
            /* e.g. score 100 will have rank 1, since scores[101] is 1 */
            for(int score = 100; score >= students[stu].score[j]; score--)
                ranks[j] += scores[j][score + 1];
            if(ranks[j] <= ranks[max]) /* The best rank with highest priority */
                max = j;
        }
        printf("%d %c\n", ranks[max], "ACME"[max]);
    }
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 200,738评论 5 472
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 84,377评论 2 377
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 147,774评论 0 333
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,032评论 1 272
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,015评论 5 361
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,239评论 1 278
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,724评论 3 393
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,374评论 0 255
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,508评论 1 294
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,410评论 2 317
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,457评论 1 329
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,132评论 3 316
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,733评论 3 303
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,804评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,022评论 1 255
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 42,515评论 2 346
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,116评论 2 341

推荐阅读更多精彩内容