逃离迷宫
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23452 Accepted Submission(s): 5760
Problem Description
给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
Input
第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2 ≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。
Output
每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
Sample Input
2
5 5
...**
..
.....
.....
....
1 1 1 1 3
5 5
...
.*.
.....
.....
*....
2 1 1 1 3
Sample Output
no
yes
题意:
给定m*n的迷宫,k为最大转弯次数,问能否到达终点。
思路:
通常的BFS必定超时,这里以k为底进行BFS,每到达一个节点就4个方向走到底,更新没到过的节点的转弯数(原位置的转弯数+1),保证找到的解是转弯数最小的解。
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct Node {
int x, y;
};
const int maxn = 100 + 5;
char buf[maxn][maxn];
int turn[maxn][maxn];
int m, n;
int k, x, y, goalx, goaly;
int ud[4] = { -1, 1, 0, 0 };
int lr[4] = { 0, 0, -1, 1 };
bool check(const Node& node) {
if (node.x > 0 && node.x <= m && node.y > 0 && node.y <= n) {
if (buf[node.x][node.y] != '*')
return true;
}
return false;
}
bool bfs() {
queue<Node> que;
Node now;
Node tmp;
now.x = x;
now.y = y;
que.push(now);
while (!que.empty()) {
now = que.front();
que.pop();
for (int i = 0; i < 4; ++i) {
tmp.x = now.x + ud[i];
tmp.y = now.y + lr[i];
while (check(tmp)) {
if (turn[tmp.x][tmp.y] == -1) {
turn[tmp.x][tmp.y] = turn[now.x][now.y] + 1;
if (tmp.x == goalx && tmp.y == goaly && turn[tmp.x][tmp.y] <= k) {
return true;
}
que.push(tmp);
}
tmp.x += ud[i];
tmp.y += lr[i];
}
}
}
return false;
}
int main() {
int T;
while (scanf("%d", &T) != EOF) {
while (T--) {
memset(turn, -1, sizeof(turn));
scanf("%d%d", &m, &n);
for (int i = 1; i <= m; ++i)
scanf("%s", buf[i] + 1);
scanf("%d%d%d%d%d", &k, &y, &x, &goaly, &goalx);
if ((x == goalx && y == goaly) || bfs())
printf("yes\n");
else
printf("no\n");
}
}
return 0;
}