PAT-1030-Travel Plan

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:
City1 City2 Distance Cost
where the numbers are all integers no more than 500, and are separated by a space.
Output Specification:
For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.
Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

#include <iostream>
#include <fstream>
#include <vector>
#define N 505
#define INF 0x7fffffff
#define min(x, y) x < y ? x : y

using namespace std;

struct Node{
    int no, dis, cos;
};

vector<Node> node[N];
int path[N];
bool mark[N];
int dist[N], cost[N];

void DFS(int dest)
{
    if(path[dest] == -1)
        return;

    DFS(path[dest]);
    cout << path[dest] << " ";
}

int main()
{
    ifstream cin("in.txt");

    int n, m, s, d;

    while(cin >> n >> m >> s >> d)
    {
        for(int i = 0; i < n; ++i)
        {
            node[i].clear();
            path[i] = -1;
            mark[i] = false;
            dist[i] = cost[i] = INF;
        }

        for(int i = 0; i < m; ++i)
        {
            int a, b, dis, cos;
            Node tmp;
            cin >> a >> b >> dis >> cos;

            tmp.no = b;
            tmp.dis = dis;
            tmp.cos = cos;

            node[a].push_back(tmp);
            tmp.no = a;
            node[b].push_back(tmp);
        }

        int newP = s;
        dist[newP] = 0;
        cost[newP] = 0;
        mark[newP] = true;
        
        for(int i = 1; i < n; ++i)
        {
            for(int j = 0; j < node[newP].size(); ++j)
            {
                int no = node[newP][j].no;
                int dis = node[newP][j].dis;
                int cos = node[newP][j].cos;

                if(mark[no] == true)
                    continue;

                if(dist[no] == INF || dist[no] > dist[newP] + dis || (dist[no] == dist[newP] + dis && cost[no] > cost[newP] + cos))
                {
                    dist[no] = dist[newP] + dis;
                    cost[no] = cost[newP] + cos;

                    path[no] = newP;
                }
            }
            int maxDis = INF;
            int maxCost = INF;

            for(int j = 0; j < n; ++j)
            {
                if(dist[j] == INF || mark[j] == true)
                    continue;

                if(dist[j] < maxDis || (dist[j] == maxDis && cost[j] < maxCost))
                {
                    maxDis = dist[j];
                    maxCost = cost[j];
                    newP = j;
                }
            }

            mark[newP] = true;
        }

        DFS(d);
        cout << d << " " << dist[d] << " " << cost[d];
    }

    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 194,670评论 5 460
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 81,928评论 2 371
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 141,926评论 0 320
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 52,238评论 1 263
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 61,112评论 4 356
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 46,138评论 1 272
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 36,545评论 3 381
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 35,232评论 0 253
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 39,496评论 1 290
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 34,596评论 2 310
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 36,369评论 1 326
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,226评论 3 313
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 37,600评论 3 299
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 28,906评论 0 17
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,185评论 1 250
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 41,516评论 2 341
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 40,721评论 2 335

推荐阅读更多精彩内容

  • 今日心享~享受自然 大自然,是天然的净化器,它完全在洗涤我的身体! 我享受风,它可以轻微抚摸我的头发; 我享受雨,...
    吸引力修炼阅读 251评论 0 3
  • 这应该是最近第二次被问开不开心吧,说实在被问及时,我有那么一丝尴尬,不知道该怎么回答。我甚至百度了释义:开心,基本...
    自由和安阅读 162评论 2 1
  • 另一个意思是,事后可反思。 你还要好的朋友约着出去看电影,但是到快要出去的时候,有没有见到他的人,给他电话也打不通...
    山人Shan阅读 270评论 0 0
  • 1.逍遥叹 爱已走到尽头/恨也放弃承诺/命运自认幽默/想法太多/由不得我/壮志凌云几分愁/知己难逢几人留/再回首/...
    纠缠的离骚阅读 570评论 16 10
  • 佛说五百次回眸,换来今生的擦肩而过。 东北下雪了。整个白色的世界里我认识了你。你好,我叫马克(这是真名,英文也一样...
    Mark_ME阅读 207评论 0 0