POJ 1611 - The Suspects

POJ 1611 - The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题目大意:
n个人,如果有一个人感染了SARS病毒,那么和这个人同组的人都会感染病毒。也就是说和被感染的人有关系的人都感染了病毒。
输入:n m n为成员个数 m为组数
输出:被感染的人数
定义 num[] 数组,num[i] 表示 i 所在集合的元素数量。 初始化 num[] 数组全为 1,每次合并的时候就更新每组代表元素的num[] 值。
最后输出的时候先找到被感染的0号的父节点,然后输出父节点的num[].

解题思路:

  • 定义 num[] 数组,num[i] 表示 i 所在集合的元素数量。
  • 初始化 num[] 数组全为 1,每次合并的时候就更新每组代表元素的num[] 值。
  • 最后输出的时候先找到被感染的0号的父节点,然后输出父节点的num[].
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
const int MAX = 30000;

int fa[MAX], deep[MAX], num[MAX];

void init()
{
    memset(fa, -1, sizeof(fa));
    memset(deep, 0, sizeof(deep));
}

int find(int x)
{
    if (fa[x] == -1) return x;
    return fa[x] = find(fa[x]);
}

void unite(int x, int y)
{
    x = find(x), y = find(y);
    if (x == y) return;
    if (deep[x]<deep[y]) {
        fa[x] = y;
        num[y] += num[x];//y为代表元素 将num[x]里面的数量加到num[y]里
    }
    else
    {
        fa[y] = x;
        if (deep[x] == deep[y])
            deep[x]++;
        num[x] += num[y];
    }
}

bool same(int x, int y)
{
    return find(x) == find(y);
}


int main()
{
    int n, m;
    int k;
    int x, y;
    while (scanf("%d%d", &n, &m) && n != 0 || m != 0) {
        if (n > MAX || m > 500) break;
        init();
        for (int i = 0; i < n; i++)
        {
            num[i] = 1;//初始化num为1
        }
        while (m--) {
            scanf("%d%d", &k, &x);//这里输入 组内成员个数k 和 每组第一个代表元素x
            for (int i = 1; i < k; i++)
            {
                scanf("%d", &y);
                unite(x, y);

            }

        }
        printf("%d\n", num[find(0)]);//先找0的父节点 然后输出集合内元素个数

    }

    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 194,761评论 5 460
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 81,953评论 2 371
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 141,998评论 0 320
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 52,248评论 1 263
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 61,130评论 4 356
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 46,145评论 1 272
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 36,550评论 3 381
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 35,236评论 0 253
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 39,510评论 1 291
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 34,601评论 2 310
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 36,376评论 1 326
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,247评论 3 313
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 37,613评论 3 299
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 28,911评论 0 17
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,191评论 1 250
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 41,532评论 2 342
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 40,739评论 2 335

推荐阅读更多精彩内容

  • **2014真题Directions:Read the following text. Choose the be...
    又是夜半惊坐起阅读 9,250评论 0 23
  • 看来贴吧的幽灵楼是大限将至了,昨天掐指一算,就觉得难逃一劫,颤颤巍巍,本以为可以躺平坑底,看来还是不适合太招摇...
    等猴抱兔阅读 1,085评论 26 17
  • 今天是胖头胖脑的二头身Q版漫画。 所以,你希望你的小孩是哪种类型的小可爱呢?
    向着你走阅读 393评论 0 5
  • 今天是7月26日,来延安的第24天,依然是停工状态。 今天下午有一件事冲淡了我们整日无聊的生活,睁开午休的眼睛,习...
    帅气的大哥哥6阅读 378评论 0 2
  • 板绘
    三青w阅读 206评论 0 1