HDOJ 1002 A + B Problem II

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

分析

大整数相加问题。另外输出的格式需要注意

#include <stdio.h>
int main()
{
    int n;
    int no=0;
    char a[1001],b[1001];
    scanf("%d",&n);
    while(n--)
    {
        if(no!=0)
            printf("\n");
        no++;
        scanf("%s %s",&a,&b);
        int alength=0;
        while(a[alength]!='\0')
            alength++;
        int blength=0;
        while(b[blength]!='\0')
            blength++;
        int length=alength;
        if(length>blength)
            length=blength;
        int ans[1001];
        for(int i=0;i<1001;i++)
            ans[i]=0;
        for(int i=0;i<length;i++)
        {
            int t1=a[alength-1-i]-'0';
            int t2=b[blength-1-i]-'0';
            if(t1+t2+ans[i]>9)
            {
                ans[i]=(t1+t2+ans[i])%10;
                ans[i+1]=1;
            }
            else
            {
                ans[i]=t1+t2+ans[i];
            }
        }
        if(length<alength)
        {
            for(int i=length;i<alength;i++)
            {
                if(a[alength-1-i]-'0'+ans[i]>9)
                {
                    ans[i]=(a[alength-1-i]-'0'+ans[i])%10;
                    ans[i+1]=1;
                }
                else
                {
                    ans[i]=a[alength-1-i]-'0'+ans[i];
                }
            }
        }
        if(length<blength)
        {
            for(int i=length;i<blength;i++)
            {
                if(b[blength-1-i]-'0'+ans[i]>9)
                {
                    ans[i]=(b[blength-1-i]-'0'+ans[i])%10;
                    ans[i+1]=1;
                }
                else
                {
                    ans[i]=b[blength-1-i]-'0'+ans[i];
                }
            }
        }
        printf("Case %d:\n",no);
        printf("%s + %s = ",a,b);
        int anslength=1000;
        while(ans[anslength]==0)
            anslength--;
        for(int i=anslength;i>=0;i--)
            printf("%d",ans[i]);
        printf("\n");
    }
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 200,961评论 5 473
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 84,444评论 2 377
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 148,009评论 0 333
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,082评论 1 272
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,101评论 5 363
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,271评论 1 278
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,738评论 3 393
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,395评论 0 255
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,539评论 1 294
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,434评论 2 317
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,481评论 1 329
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,160评论 3 317
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,749评论 3 303
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,816评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,038评论 1 256
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 42,548评论 2 346
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,140评论 2 341

推荐阅读更多精彩内容

  • 背景 一年多以前我在知乎上答了有关LeetCode的问题, 分享了一些自己做题目的经验。 张土汪:刷leetcod...
    土汪阅读 12,716评论 0 33
  • **2014真题Directions:Read the following text. Choose the be...
    又是夜半惊坐起阅读 9,309评论 0 23
  • 请不要再说什么, 我明白你的心情。 就让我们微笑着说声保重, 再挥手送走,昨日伤痛, 哪怕分别后,痛哭失声, 这一...
    项楠阅读 124评论 0 1
  • 宋胖子有句歌词:我也是个复杂的动物,嘴上一句带过心里却一直重复。我想有时候就是这样的吧,嘴上逞强,心里却一点也不放...
    1358阅读 4,007评论 0 2
  • 泛型泛型就是指参数化类型,用符号标记是实际类型的占位符,是从JDK1.5出现的新特性。泛型可分为:泛型类泛型方法泛...
    罗伯特胡萝卜皮阅读 830评论 0 9