实验2-4-3 求平方根序列前N项和 (15 分)
1. 题目摘自
https://pintia.cn/problem-sets/13/problems/414
2. 题目内容
本题要求编写程序,计算平方根序列√1+√2 +√3+⋯的前N项之和。可包含头文件 math.h
,并调用 sqrt
函数求平方根。
输入格式:
输入在一行中给出一个正整数N。
输出格式:
在一行中按照“sum = S”的格式输出部分和的值S,精确到小数点后两位。题目保证计算结果不超过双精度范围。
输入样例:
10
输出样例:
sum = 22.47
3. 源码参考
#include <iostream>
#include <math.h>
#include <iomanip>
using namespace std;
int main()
{
int n;
double s;
cin >> n;
s = 0;
for(int i = i; i <= n; i++)
{
s += sqrt(i);
}
cout << "sum = " << fixed << setprecision(2) << s << endl;
return 0;
}