Tunnels - 第四届全国中医药院校大学生程序设计竞赛

问题描述

There are n holes and n-1 tunnels connecting them. The holes are labeled by 1,2,...,n. For all i>1, a hole number i is connected by a tunnel to the hole number ⌊i/2⌋. Tunnels are all bidirectional.

Initially, all the tunnels are available. There will be m events happened in the tunnel system. The i-th event will change the status of the tunnel between u_i and ⌊u_i/2⌋. If this tunnel is available, it will become unavailable, and if this tunnel is unavailable, it will become available.

Please write a program to support these events, and report the number of pairs i,j(1 <= i < j <= n) that holes i,j are still connected after each event.

输入

The first line of the input contains an integer T(1 <= T <= 5), denoting the number of test cases.

In each test case, there are two integers n,m(2 <= n,m <= 100000) in the first line, denoting the number of holes and the number of events.

For the next m lines, each line contains an integer u_i(2 <= u_i <= n), denoting an event.

输出

For each test case, print m lines. The i-th line contains an integer, denoting the number of connected pairs after the i-th event.

样例输入

1
9 6
6
4
2
4
4
3

样例输出

28
13
7
13
7
5

解题思路

这是一个不那么好做的题,但仔细想想,还是简单的。

题目有点长,读下来,意思其实也很清晰。

由于他是n个点,n - 1条边,所以很显然是一个简单图,还是一棵树。

继续读下去,你会发现,这不就是一个用数组存的完全二叉树)吗。

那我们观察下,看看联通是怎么计算的。

根据样例,如果把6号节点移除了,那么剩下还有28条联通对,那是哪28条呢?

观察规律,我们发现:
对于9号节点来说:

[9 - 4], [9 - 8], [9 - 2], [9 - 5], [9 - 1], [9 - 3], [9 - 7]

也就是有7对联通对
对于8号节点来说:

[8 - 4], [8 - 2], [8 - 5], ..., [8 - 7]

也就是除去[8 - 9]这对重复的,剩下来的6对。

规律发现了,也就是说,8个节点互相联通,那么联通对的数量是:7+6+5+4+3+2+1 = 28,简单的来说,就是(7 + 1) \times7 \div 2 = 28

那么思路就来了,只要知道当前联通块的节点数k,那么该联通块的联通对数p就很容易算出了:p = k * ( k - 1) / 2

有了这个概念,那么就直接暴力(也就O(log_n)嘛)一波走起了。

为了方便,我开两个数组ab,分别记录a_i下的子节点数(包括a_i自身)b_i下的联通对数

表格

建树

有了理论基础,那就用代码来对ab数组初始化一下。

for (int i = n;i >= 1;i --)
{
    t = i * 2 + 1;
    if (t > n) t = 0;
    else t = a[t];
    a[i] = t;
    t = i * 2;
    if (t > n) t = 0;
    else t = a[t];
    a[i] += t + 1;
    b[i] = a[i] * (a[i] - 1) / 2;
}

由于数据最大是100000,所以b数组算出来最大有4999950000之大,得用long long了。

然后呢,我们用一个变量v来记录一下总共的联通块,以便后续操作之用。

long long v = b[1];

操作

剩下的,便是我们的操作。

根据题意,每一次操作都会翻转联通与否,所以我们还得记一笔联通情况。

int k[100010];
memset(k, -1, sizeof(k)); // -1代表,一开始都联通

因此我们可以开始读入:

for (int i = 0;i < m;i ++)
{
    scanf("%lld",&t);
    k[t] = !k[t];
    if (k[t]) add(t);
    else remove(t);
    printf("%lld\n",v);
}

这样,程序的主体便完成了。

那么我们来看看removeadd方法。

void add(long long i)
{
    v -= b[i];
    update(i);
}

void remove(long long i)
{
    v += b[i];
    update(i);
}

思路也很简单。

对于移除节点:先让总联通块数v加上他自身的子联通块数b[i](因为:一旦一个联通块失去联系,那么作为这个联通块本身也就独立了,所以只要让总数v加上这个独立的联通对数),之后,再一步步更新上去即可;

对于添加节点:先让总联通块数v减去他自身的子联通块数b[i](因为:当一个独立的联通块恢复链接之后,那它原来加上去的子联通块数也没有用了,所以得减去),之后,再一步步更新上去即可。

到目前为止,就剩下如何更新了。

那么我们来更新吧(注释非常详细哦)。

void update(long long i)
{
    long long c1 = 0, c2 = 0;
    i /= 2; // 首先强制更新进行过add/remove操作的父节点的状态
    long long h = 0; // 开一个变量用于记录
    if (i * 2 <= n && k[i * 2]) c1 = a[i * 2]; // 如果a[i]有左节点联通,那就记录下他左节点的子节点数
    if (i * 2 + 1 <= n && k[i * 2 + 1]) c2 = a[i * 2 + 1]; // 如果a[i]有右节点联通,那就记录下他右节点的子节点数
    a[i] = c1 + c2 + 1; // 求和并+1来更新自己的子节点数(包括a[i]自己,所以+1)
    h = b[i]; // 记录下更新之前的子联通块数
    b[i] = a[i] * (a[i] - 1) / 2; // 用之前找规律所得的公式来更新b[i]
    while (k[i]) // 如果a[i]上面继续联通着父亲节点,那就一路更新上去吧
    {
        i /= 2;
        c1 = c2 = 0;
        if (i * 2 <= n && k[i * 2]) c1 = a[i * 2];
        if (i * 2 + 1 <= n && k[i * 2 + 1]) c2 = a[i * 2 + 1];
        a[i] = c1 + c2 + 1;
        h = b[i];
        b[i] = a[i] * (a[i] - 1) / 2;
    }
    v -= h; // 最后更新全局所有联通块数v,先减去先前的b[i],也就是先前操作的这个联通块之前的联通对数
    v += b[i]; // 更新成现在的
}

最后,来一个动画解释一波。

移除
添加

代码

好吧,老规矩,还是给一个ac代码吧。

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <vector>
#include <list>
#include <set>
#include <utility> // pair
#include <map>
#include <iostream>
#include <sstream>
#include <algorithm> // sort
#include <string>
#include <stack>
#include <queue>
#include <fstream>

using namespace std;

#define ll long long
#define uchar unsigned char
#define ushort unsigned short
#define uint unsigned int
#define ulong unsigned long
#define ull unsigned long long

#define pi acos(-1)

#define mx(a,b) (a) > (b) ? (a) : (b)
#define mn(a,b) (a) < (b) ? (a) : (b)
#define mem(a,b) memset(a,b,sizeof(a))
#define fre(a) freopen(a,"r",stdin)

#define itn int
#define nit int
#define inr int
#define mian main
#define ednl endl
#define fro for
#define fir for
#define reutrn return
#define retunr return

ll a[100010];
ll b[100010];
int k[100010];

ll v;
int n,m;

void update(ll i)
{
    ll c1 = 0, c2 = 0;
    i /= 2;
    ll h = 0;
    if (i * 2 <= n && k[i * 2]) c1 = a[i * 2];
    if (i * 2 + 1 <= n && k[i * 2 + 1]) c2 = a[i * 2 + 1];
    a[i] = c1 + c2 + 1;
    h = b[i];
    b[i] = a[i] * (a[i] - 1) / 2;
    while (k[i])
    {
        i /= 2;
        c1 = c2 = 0;
        if (i * 2 <= n && k[i * 2]) c1 = a[i * 2];
        if (i * 2 + 1 <= n && k[i * 2 + 1]) c2 = a[i * 2 + 1];
        a[i] = c1 + c2 + 1;
        h = b[i];
        b[i] = a[i] * (a[i] - 1) / 2;
    }
    v -= h;
    v += b[i];
}

void add(ll i)
{
    v -= b[i];
    update(i);
}

void remove(ll i)
{
    v += b[i];
    update(i);
}

int main()
{
    int T;
    scanf("%d",&T);
    ll t;
    while (T --)
    {
        scanf("%d %d",&n,&m);
        mem(k,-1);
        k[0] = 0;
        k[1] = 0;
        for (int i = n;i >= 1;i --)
        {
            t = i * 2 + 1;
            if (t > n) t = 0;
            else t = a[t];
            a[i] = t;
            t = i * 2;
            if (t > n) t = 0;
            else t = a[t];
            a[i] += t + 1;
            b[i] = a[i] * (a[i] - 1) / 2;
        }
        v = b[1];
        for (int i = 0;i < m;i ++)
        {
            scanf("%lld",&t);
            k[t] = !k[t];
            if (k[t]) add(t);
            else remove(t);
            printf("%lld\n",v);
        }
    }
    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 202,056评论 5 474
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 84,842评论 2 378
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 148,938评论 0 335
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,296评论 1 272
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,292评论 5 363
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,413评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,824评论 3 393
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,493评论 0 256
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,686评论 1 295
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,502评论 2 318
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,553评论 1 329
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,281评论 4 318
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,820评论 3 305
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,873评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,109评论 1 258
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 42,699评论 2 348
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,257评论 2 341

推荐阅读更多精彩内容