ACM 之 E - Rails

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The stationwas built in last century. Unfortunately, funds were extremely limited that time. It was possible toestablish only a surface track. Moreover, it turned out that the station could be only a dead-end one(see picture) and due to lack of available space it could have only one track.

示意图

The local tradition is that every train arriving from the direction A continues in the directionB with coaches reorganized in some way. Assume that the train arriving from the direction A hasN ≤ 1000 coaches numbered in increasing order 1, 2, . . . , N . The chief for train reorganizations mustknow whether it is possible to marshal coaches continuing in the direction B so that their order willbe a1.a2, . . . , aN . Help him and write a program that decides whether it is possible to get the requiredorder of coaches. You can assume that single coaches can be disconnected from the train before theyenter the station and that they can move themselves until they are on the track in the direction B. Youcan also suppose that at any time there can be located as many coaches as necessary in the station.But once a coach has entered the station it cannot return to the track in the direction A and also onceit has left the station in the direction B it cannot return back to the station.

Input

The input le consists of blocks of lines. Each block except the last describes one train and possiblymore requirements for its reorganization. In the rst line of the block there is the integer N describedabove. In each of the next lines of the block there is a permutation of 1, 2, . . . , N. The last line of theblock contains just ‘0’.
The last block consists of just one line containing ‘0’.

Output

The output le contains the lines corresponding to the lines with permutations in the input le. A lineof the output le contains ‘Yes’ if it is possible to marshal the coaches in the order required on thecorresponding line of the input le. Otherwise it contains ‘No’. In addition, there is one empty line afterthe lines corresponding to one block of the input le. There is no line in the output le correspondingto the last “null” block of the input le.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes

理解:

这个比较简单,也是我第一次接触 栈 ,和stack关键词 , 这个可以和队列一起学习.

代码部分

#include<iostream>
#include<stack>
using namespace std;
int main()
{
    stack<int>s;
    stack<int>ss;
    int n,n1,a[1001];
    while(cin>>n)
    {
        if(n==0)
            return 0;
        while(cin>>n1)
        {
            if(n1==0)
                break;
            s.push(n1);
            for(int i=1;i<n;i++)
            {
                cin>>n1;
                s.push(n1);
            }
            while(!s.empty())
            {
                ss.push(s.top());
                s.pop();
            }
            while(!ss.empty())
            {
                int k=0,ff=0,fff=0;
                for(int j=0;j<n;j++)
                {
                    a[k]=ss.top();
                    ss.pop();
                    k++;
                }
                if(a[0]<a[1])
                {
                    for(int y=0;y<n-1;y++)
                    {
                        if(a[y]<a[y+1])
                            ff++;
                        if(a[y]==a[y+1])
                        {
                            ff++;
                        }
                    }
                    if(ff==n-1)
                    {
                        cout<<"Yes\n";
                    }
                    if(ff!=n-1)
                    {
                        cout<<"No\n";
                    }
                }
                if(a[0]>=a[1])
                {
                    for(int y=0;y<n-1;y++)
                    {
                        if(a[y]>a[y+1])
                            fff++;
                        if(a[y]==a[y+1])
                        {
                            fff++;
                        }
                    }
                    if(fff==n-1)
                    {
                        cout<<"Yes\n";
                    }
                    if(fff!=n-1)
                        cout<<"No\n";
                }
            }
        }cout<<endl;
    }
    return 0;
}

意见反馈 || 任何建议

联系我(新浪)
邮箱:qianlizhihao@gmail.com

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 199,519评论 5 468
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 83,842评论 2 376
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 146,544评论 0 330
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 53,742评论 1 271
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 62,646评论 5 359
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,027评论 1 275
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,513评论 3 390
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,169评论 0 254
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,324评论 1 294
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,268评论 2 317
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,299评论 1 329
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,996评论 3 315
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,591评论 3 303
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,667评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,911评论 1 255
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 42,288评论 2 345
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 41,871评论 2 341

推荐阅读更多精彩内容