This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
where is the number of nonzero terms in the polynomial, and are the exponents and coefficients, respectively. It is given that .
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
My Code
#include <iostream>
using namespace std;
void do_union(double exponents_all[]);
int main()
{
int n, exponents;
double coefficients;
double exponents_all[1000] = { 0 };
//int output_all[10];
for (int i = 0; i < 2; i++)
{
cin >> n;
while (n != 0)
{
cin >> exponents >> coefficients;
exponents_all[exponents] += coefficients;
n--;
}
}
do_union(exponents_all);
}
void do_union(double exponents_all[])
{
int count = 0;
for (int i = 999; i >= 0; i--)
{
if (exponents_all[i] != 0)
count++;
}
cout << count;
for (int j = 999; j >= 0; j--)
{
if (exponents_all[j] != 0)
printf(" %d %.1f", j, exponents_all[j]);
}
}
疑惑
- 我的代码提交之后,有一个样例没有通过,扣了两分,我感到非常疑惑。
- 由于陈越姥姥并没有公布测试样例是什么,根据我的经验,可能是存在输入的系数为0的情况。
- 根据题目,他并没有限制系数为0的情况,然而为了方法更简洁,我在
void do_union(double exponents_all[])
里的for
循环将系数为0的情况跳过了。 - 暂时没想到更简洁的方法,错了就错了吧。如果有朋友看出来问题,敬请斧正