1094.The Largest Generation

题目描述

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

考点

1.树;
2.遍历。

思路

1.我的思路(复杂)
一开始想到使用二维数组,但是觉得开二维数组建树浪费空间。于是考虑使用结构体数组。采用孩子-兄弟结点的形式存储树。因为一开始是乱序输入的,所以最后还需要从根结点开始,不断调整树。
2.柳神的思路
我写了大概一个半小时AC,然后一看柳神的直接开二维数组建树。我吐血了。

代码

1.我的代码(复杂版)

#include <iostream>
#include <vector>
using namespace std;
typedef struct node {
    int val;  //当前的值
    int level;  //当前的层数
    int num;   //当前层结点个数
    struct node *subling;
    int next;
}node;
vector<node> tree;
int n;
//递归调整
void generation(int r, int level) {
    //结束条件
    if (r == 0) {
        return;
    }
    int f = r, first=0, s=0;
    node *p = tree[f].subling, *q;
    tree[f].level = level; 
    while (p!=NULL) {
        int m = tree[p->val].next;
        if (m != 0) {
            first++;
            //记录第一个非叶子结点
            //将下一代所有结点都插入到这个结点的孩子结点
            if (first == 1) {
                s = m;
            }
            else {
                q = tree[m].subling;
                //头插法
                //将当前结点的所有孩子结点插入到
                //这一代的第一个非叶子结点的孩子结点
                while (q != NULL) {
                    node *temp = q->subling;
                    q->subling = tree[s].subling;
                    tree[s].subling = q;
                    tree[m].subling = temp;
                    //调整每一层的个数
                    tree[s].num++;
                    tree[m].num--;
                    q = temp;
                }
            }
        }
        p = p->subling;
    }
    generation(s, level + 1);
}
void findMax() {
    int i = 1, max=0, level;
    for (; i <= n; i++) {
        if (tree[i].num > max) {
            max = tree[i].num;
            level = tree[i].level;
        }
    }
    cout << max << " " << level << endl;
}
int main() {
    int i, j, m;
    cin >> n >> m;
    tree.resize(n+1);
    for (i = 0; i < m; i++) {
        int p, n, f;
        cin >> p >> n;
        tree[p].level = 0; tree[p].val = p;
        for (j = 0; j < n; j++) {
            int v; cin >> v;
            if (j == 0) {
                f = v;
                tree[f].level = 0; tree[f].num = n; tree[f].val = f;
            }
            node *q = new node();
            q->val = v; q->level = 0; q->num = n;
            q->subling = tree[f].subling;
            tree[f].subling = q;
        }
        tree[p].next = f;
    }
    if (m == 0) { tree[1].num = 1; tree[1].level = 1; }
    generation(tree[1].next, 2);
    findMax();
    return 0;
}

2.柳神版(代码先贴上,我先去心痛一会了~~)

#include <cstdio>
#include <vector>
using namespace std;
vector<int> v[100];
int book[100];
void dfs(int index, int level) {
    book[level]++;
    for(int i = 0; i < v[index].size(); i++)
        dfs(v[index][i], level+1);
}
int main() {
    int n, m, a, k, c;
    scanf("%d %d", &n, &m);
    for(int i = 0; i < m; i++) {
        scanf("%d %d",&a, &k);
        for(int j = 0; j < k; j++) {
            scanf("%d", &c);
            v[a].push_back(c);
        }
    }
    dfs(1, 1);
    int maxnum = 0, maxlevel = 1;
    for(int i = 1; i < 100; i++) {
        if(book[i] > maxnum) {
            maxnum = book[i];
            maxlevel = i;
        }
    }
    printf("%d %d", maxnum, maxlevel);
    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 203,179评论 5 476
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 85,229评论 2 380
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 150,032评论 0 336
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,533评论 1 273
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,531评论 5 365
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,539评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,916评论 3 395
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,574评论 0 256
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,813评论 1 296
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,568评论 2 320
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,654评论 1 329
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,354评论 4 318
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,937评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,918评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,152评论 1 259
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 42,852评论 2 349
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,378评论 2 342

推荐阅读更多精彩内容