sicily_1046 Plane Spotting

题目

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Craig is fond of planes. Making photographs of planes forms a major part of his daily life. Since he tries to stimulate his social life, and since it’s quite a drive from his home to the airport, Craig tries to be very efficient by investigating what the optimal times are for his plane spotting. Together with some friends he has collected statistics of the number of passing planes in consecutive periods of fifteen minutes (which for obvious reasons we shall call ‘quarters’). In order to plan his trips as efficiently as possible, he is interested in the average number of planes over a certain time period. This way he will get the best return for the time invested. Furthermore, in order to plan his trips with his other activities, he wants to have a list of possible time periods to choose from. These time periods must be ordered such that the most preferable time period is at the top, followed by the next preferable time period, etc. etc. The following rules define which is the order between time periods:

  1. A period has to consist of at least a certain number of quarters, since Craig will not drive three hours to be there for just one measly quarter.
  2. A period P1 is better than another period P2 if:
  • the number of planes per quarter in P1 is higher than in P2;
  • the numbers are equal but P1 is a longer period (more quarters);
  • the numbers are equal and they are equally long, but period P1 ends earlier.

Now Craig is not a clever programmer, so he needs someone who will write the good stuff: that means you. So, given input consisting of the number of planes per quarter and the requested number of periods, you will calculate the requested list of optimal periods. If not enough time periods exist which meet requirement 1, you should give only the allowed time periods.

Input

The input starts with a line containing the number of runs N. Next follows two lines for each run. The first line contains three numbers: the number of quarters (1–300), the number of requested best periods (1–100) and the minimum number of quarters Craig wants to spend spotting planes (1–300). The sec-nod line contains one number per quarter, describing for each quarter the observed number of planes. The airport can handle a maximum of 200 planes per quarter.

Output

The output contains the following results for every run:

  • A line containing the text “Result for run <N>:” where <N> is the index of the run.

  • One line for every requested period: “<F>-<L>” where <F> is first quarter and <L> is the last quarter of the period. The numbering of quarters starts at 1. The output must be ordered such that the most preferable period is at the top.

Sample Input

3
10 5 5
1 5 0 2 1 4 2 5 0 2
10 3 5
10 3 1 4 2 6 3 0 8 0
5 5 5
1 2 3 4 5

Sample Output

Result for run 1:
4-8
2-8
6-10
1-8
2-6
Result for run 2:
1-6
1-7
1-9
Result for run 3:
1-5

题目大意

Craig喜欢看飞机,但是没有太多业余时间,收集了一些航班的数据,请利用这些数据找出最符合Craig的时段(period),每个时期包含多个quarter,用首尾两个quarter的序号表示一段时期。

(对应代码中的标识符)
多组数据,数据组数runs
每组数据两行:
第一行:有多少个15分钟时段quarters(1-300) 要最优先的多少个时期requested(1-100) 每个时期最少要多长min(1-300)
第二行:每个quarter的航班数(0-200)

思路

  1. 利用结构体存储periods信息;
  2. 判断结构体两个periods的优先顺序:
    1. period每quarter的航班数不同,多的优先;
    2. 航班数相同,period持续时间长的优先;
    3. 以上两者均相同,早结束的优先;
  3. 选出最符合条件的requested个时期

代码

// Copyright (c) 2015 HuangJunjie@SYSU(SNO:13331087). All Rights Reserved.
// sicily_1046 plane_spotting: http://soj.sysu.edu.cn/1046
#define MAX_SIZE 300
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;

struct Period {
  float average;
  int length;
  int end;
};

bool operator< (const Period &a, const Period &b) {
  if (fabs(a.average - b.average) > 1e-6) return a.average > b.average;
  if (a.length != b.length) return a.length > b.length;
  return a.end < b.end;
}

int main() {
  int runs;
  cin >> runs;
  int quarters, requested, min;
  int quars[MAX_SIZE + 1];   // abandons quars[0]
  Period periods[MAX_SIZE*MAX_SIZE];

  for (int run = 1; run <= runs; run++) {
    cin >> quarters >> requested >> min;
    for (int i = 1; i <= quarters; i++) {
      cin >> quars[i];
    }

    int count = 0;
    for (int i = 1; i <= quarters; i++) {
      int sum = 0;
      for (int j = i; j <= quarters; j++) {
        sum += quars[j];
        if (j - i + 1 >= min) {
          periods[count].length = j - i + 1;
          periods[count].end = j;
          periods[count].average = (double)sum / (j - i + 1);
          count++;
        }
      }
    }
    sort(periods, periods + count);

    cout << "Result for run " << run << ":" << endl;
    for (int i = 0;i < requested && i < count; i++) {
      cout << periods[i].end - periods[i].length + 1;
      cout << "-" << periods[i].end << endl;
    }
  }
  return 0;
}

参考

http://blog.csdn.net/qiuchenl/article/details/8253207

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 203,098评论 5 476
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 85,213评论 2 380
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 149,960评论 0 336
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,519评论 1 273
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,512评论 5 364
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,533评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,914评论 3 395
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,574评论 0 256
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,804评论 1 296
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,563评论 2 319
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,644评论 1 329
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,350评论 4 318
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,933评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,908评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,146评论 1 259
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 42,847评论 2 349
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,361评论 2 342

推荐阅读更多精彩内容